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Introduction

This guide describes how to install, set up, and run the Call Classifier Add-on features 
for the Strata Communication Server (CS).

Conventions

Conventions Description

Note
Elaborates specific items or references other information. 
Within some tables, general notes apply to the entire table 
and numbered notes apply to specific items.

“Type” Indicates entry of a string of text.

➤ Denotes a procedure.

➤ Denotes the step in a one-step procedure.

>
Denotes a sequence of computer menu or screen selections. 
For example: Choose Start > Programs > Call Center 
Scoreboard.

Courier Shows a computer keyboard entry or screen display.

See Figure 10

Grey words within the printed text denote cross-references. 
In the electronic version of this document (Strata CS Library 
CD-ROM or FYI Internet download), cross-references 
appear in blue hypertext.
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Related Documents/Media
Related Documents/Media
Note Some documents listed here may appear in different versions on the 

CD-ROM, FYI, or in print. To find the most current version, check the 
version/date in the Publication Information on the back of the document’s title 
page.

The following companion documentation is available:

• Strata CS Quick Reference Guide

• Strata CS Quick Reference Card

• Strata CS Digital Telephone User Guide

• Strata CS Analog Telephone User Guide

• Strata CS Library CD-ROM
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Strata CS Call Classifier

Overview
The Strata CS Call Classifier 2.0 is a powerful Strata CS Add-on Solution that can 
greatly improve the productivity of call centers. The Call Classifier lets businesses 
identify callers, intelligently route calls, and present call center agents with scripts and 
related caller information before they answer the phone.

To display detailed caller information on agents’ screens, the Call Classifier can query 
any ODBC-compliant database (for example, Microsoft® Access®, SQL Server, 
Excel, Oracle, etc.) or the ThinkDirectMarketing DigitalDATA service of more than 
120 million North American businesses and residences. In addition the Call Classifier 
can verify caller data and route callers to the optimal agent using custom business 
rules.

What You Can Do With Call Classifier
The following are examples of how you can use the Call Classifier to benefit your 
business or call center:

• Set a caller’s queue priority based on issue number, customer number, or caller ID 
to bump them up in line.

• Get detailed profile information on any business or end user from any ODBC 
database or the extensive ThinkDirectMarketing DigitalDATA service.

• Prompt callers for any numeric information, and validate it based on any ODBC 
database, then send the resulting profile information to the agent. Prevent 
nonvalidated callers from reaching an agent.

• Based on the area code that the customer is calling from, route callers to the agents 
most appropriate for that region.
Stratagy CS Call Classifier User Guide    08/02 1
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• Based on your own custom or company database, attach issue numbers, customer 
profiles, addresses, and other information to the call when customers call.

• Add agent call scripts (with optional embedded customer name) to the Call Notes 
based on caller ID and a custom database query (for example, "Is Mr. Jones 
available? This is Fred Holmes from XYZ Corp…").

• Add caller ID name where none exists by looking up the caller ID number in a 
white pages database or database of area codes and regions.

• Add meaning to DID numbers. For example, ABC corp has a different support 
phone number (using DID) for each of their products. As the Call Classifier 
receives calls, it can add the appropriate product name to the Notes field based on 
DID, then route the call to the support queue. Agents using the Call Monitor can 
see the product name before answering the call, resulting in a shorter call and a 
more informed agent.

• In conjunction with a third-party fax server, allow a single DID number to be used 
for both faxes and calls. Use Strata CS’s auto attendants for fax detection, and then 
use the Call Classifier to route calls to users if no fax is detected.

• Create a global "black list" so that all calls from a set of particular numbers are sent 
directly to voice mail or are disconnected.

• Hide certain or all caller IDs from users by setting caller ID to nothing.  

• Add address information to calls based on caller ID. If caller ID isn’t present, you 
can have the Call Classifier prompt the caller for their phone number. 

How Call Classifier Works
The Call Classifier can recognize incoming calls based on the following criteria:

• DID (the phone number dialed by the caller)

• Caller ID name or number

• Call Notes

• Custom data variables

Call recognition can be based on matching any of the above criteria to any of the 
following:

• Any number or text that you enter in a Call Classifier business rule
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Overview
• A record in your company’s ODBC database

• A record in ThinkDirectMarketing’s DigitalDATA service

Once calls are recognized, you can perform the following actions on them:

• Route them to the extension or voice mailbox of your choice

• Populate the Call Notes field with custom information

• Replace the DID number, caller ID number, or caller ID name with text of your 
choice

• Set or reset Custom Data variables attached to the calls

• Hang up on the calls

• Process additional Call Classifier business rules
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Call Progress
The following diagram illustrates call progress through the Call Classifier:
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Installation
Note Application software for this add-on application must be downloaded from the 

Toshiba FYI site at http://fyi/techsupport/software/stratasystem/cs. You must be 
CS certified to access this site. To obtain an activation license, contact your 
Toshiba Customer Service Representative.

You must shut down the Strata CS Server before installing the Call Classifier, so it’s 
best to install it after hours, when you won’t be interrupting users.

Requirements for Call Classifier
The Call Classifier requires the following:

• Microsoft Windows NT® 4.0 SP6 or higher

• Strata CS 4.0 SP1 or higher

In addition, the following are requirements to use these Call Classifier features:

• Network access to your database is required to do custom database queries (see 
“Using Custom Database Queries” on page 19).

• An account with ThinkDirectMarketing is required to use their DigitalDATA 
service (see “Get Caller Information with ThinkDirectMarketing, Inc.” on page 
27).

• Microsoft Access version 2000 or higher is required to manage the Agent Regions 
sample database (see “About Sample Configurations” on page 9), as well as the 
database containing the local cache for ThinkDirectMarketing’s DigitalDATA 
service (see “Manage DigitalDATA Cache” on page 33).

Licensing

The Call Classifier is licensed per Strata CS Server. It is also an IVR Plug-in, and 
therefore adheres to the same licensing rules that apply to IVR Plug-ins. See Strata CS 
Administrator Manual for full licensing information. The Call Classifier can handle an 
unlimited number of simultaneous calls, but each simultaneous call to the Call 
Classifier will consume one station license for the duration of the call. For example, if 
you have a system with 16 station licenses, and 15 of those stations are assigned to 
users, you have one free station license that can be used for one call to the Call 
Classifier. Before running the Call Classifier, ensure that you have adequate station 
licenses available.
Stratagy CS Call Classifier User Guide    08/02 5
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Install Strata CS Call Classifier
Make sure that the Strata CS Server is shut down before proceeding.

The rest of this section assumes that you have successfully downloaded the Call 
Classifier .zip file. Download instructions can be found on the card included in the 
Call Classifier packaging.

Note If you used Call Classifier 1.0 and you want to continue using its rules, back up 
its database file and INI file before installing Call Classifier 2.0. After 
installation, see “Import Rules from Call Classifier 1.0” on page 9.

➤ To install the Call Classifier on the Strata CS Server

1. Unzip the Classifier2.zip to a temporary location.

2. Run Setup.exe from the Classsifier2 file location. 

3. Follow the instructions in the Call Classifier Setup window.

Note You can install the Call Classifier to any PC, enabling you to manage your Call 
Classifier business rules from anywhere on the network.

Register Call Classifier as Strata CS IVR 
Plug-in

Once the Call Classifier is successfully installed, you must register it with the 
Strata CS Server as an Interactive Voice Response (IVR) Plug-in, so that its business 
rules affect Strata CS calls.

Note This procedure will require a shutdown and restart of the Strata CS Server to 
complete. Schedule this procedure for after-hours when user interruption will 
be at a minimum.

1. Start the Strata CS Administrator. 
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2. Choose File > New > IVR Plug-In. The 
IVR Plug-in screen displays (shown 
right). 

3. Enter the following information:

• Name. Name of the plug-in. This can 
be any text you choose, for example 
“Call Classifier.” 

• Extension. Extension assigned to the 
IVR plug-in. Enter any available 
extension number. 

• Program ID. Set this to 
“CCPlugin.Classifier” for the Call 
Classifier.

• Start one instance when the server is 
started. Make sure this checkbox is 
not checked.

4. If you are registering one of the sample 
configurations, or any additional Call Classifier configuration, you must 
distinguish it using a custom data variable. For instructions, see “Register Multiple 
Call Classifiers as IVR Plug-ins” on page 37.

5. Click OK to save the Call Classifier details.

Note If you see the error “The program ID does not exist on the Strata CS Server. Are 
you sure you want to use this program ID?” click No and check the text entered 
in the Program ID field. It must be set to CCPlugin.Classifier.

6. Stop and restart the Strata CS Server to complete this configuration.

Start Call Classifier
➤ To start the Call Classifier, choose Start > Programs > Toshiba Strata CS > 

Strata CS Call Classifier Administrator.

The first time you start the Call Classifier, you must enter the serial number and 
verification key to activate it.
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About Call Classifier Window
The Call Classifier window (shown below) displays the list of business rules you 
create to handle incoming calls. You can create as many rules as you want.

The title bar displays the name of the currently loaded configuration, by default 
CCPlugIn.ini. You can save and create as many different configurations as you want. 
Each configuration can have its own set of business rules. See “Use Multiple Call 
Classifier Configurations” on page 35.

Call Classifier Window Actions
You can perform the following actions on rules in the window:

• To add a new rule, click Add. See the next section.

• To edit an existing rule, select it and click Edit.

• To delete a rule, select it and click Delete.

• To reorder a rule in the list, select it and click the up or down arrow buttons.
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Ordering Business Rules in Call Classifier Window
You can have the Call Classifier apply several business rules to a call in sequence. For 
example, the first rule could identify support calls by DID and attach the name of the 
product to the DID field, then the second rule could take the Caller ID and search your 
database to find the date of this customer’s last call, attaching the information to the 
Call Notes field. To have a rule process a call after another rule, make sure the rules 
are listed with the first rule to be processed at the top and the last rule to be processed 
at the bottom. See “Add a Rule in Call Classifier” on page 13 for details.

In the case of conflicts between rules, the highest-listed rule will be used first. For 
example, you have two call rules, one that handles calls from caller ID (617) 555-1212 
and one that handles calls to DID 5001.  If a call comes in with Caller ID (617) 555-
1212 and DID 5001, the call will be handled by whichever rule is listed first.

All Calls Rule
The Call Classifier must always have at least one business rule, called the All calls 
rule, which determines what happens to a call if it is not handled by any other rules. 
By default, the All calls rule transfers calls to extension 8000, which is the default 
auto attendant extension. You can modify the All calls rule, but you cannot delete it.

Import Rules from Call Classifier 1.0
If you created rules using Call Classifier version 1.0, you can import those rules into 
Call Classifier 2.0 and continue using them. 

➤ To import rules, choose File > Import 1.0 database.

About Sample Configurations
Call Classifier 2.0 comes with three sample configurations that can get you started 
using the Call Classifier right away. You can also use the sample configurations as 
references for designing your own. The sample configurations are:

• DID to Caller ID. This sample configuration uses three business rules. It is 
designed for a call center that supports two products, each with its own phone 
number that customers call. The configuration analyzes incoming calls by DID to 
determine which product the customer is calling about, then puts the name of the 
Stratagy CS Call Classifier User Guide    08/02 9



Strata CS Call Classifier
About Sample Configurations

10
product into the Caller Id Name field of the call. Then it transfers the calls to the 
call center extension.

• Agent routing via area codes. This sample configuration uses a custom database 
query. It is designed for a North American call center with different queues that 
handle calls from different regions. The configuration analyzes incoming calls by 
the area code of the caller ID number to determine where the caller is calling from, 
and transfers each call to the extension of the queue responsible for that region. 
You can also use the sample without queues by replacing queue extensions with 
agent extensions.

• TDMI DigitalData. This sample configuration demonstrates the Call Classifier’s 
link to ThinkDirectMarketing Inc.’s DigitalDATA service, which analyzes calls by 
caller ID number and returns caller profile information such as the caller’s address. 
The configuration is designed to provide agents with as much information about 
the caller as possible. It first makes sure that caller ID is present by prompting 
callers without it to enter their phone number. Then it performs a custom database 
query by sending the caller ID number to a sample contact database 
(MyContacts.mdb, in the Call Classifier directory). If the number is found, the Call 
Notes field is updated with contact information and the call is sent to the queue. If 
no match is found, the Call Classifier performs a DigitalDATA query, first 
checking the Call Classifier’s local cache of previous DigitalDATA responses, and 
then, if no local match is found, querying the DigitalDATA service itself. The Call 
Classifier populates the Call Notes field with the result of the query (usually caller 
name and address), and then transfers the call to the queue.

View and Edit Sample Configuration
To view the business rules that make up a sample configuration, or to customize them 
for your own use, do the following:

1. Start the Call Classifier by choosing Start > Programs > Toshiba Strata CS > 
Strata CS Call Classifier Administrator.

2. Choose File > Open, and select the .INI file of the sample configuration you want 
to use. The .INI filenames are the same as the configuration names in the previous 
section.

3. To view or edit a rule, double-click it. For detailed information about rules, see the 
rest of this manual.
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Use Sample Configuration
Before using a sample configuration, you must register it as an IVR Plug-in using the 
Strata CS Administrator. For instructions see “Register Multiple Call Classifiers as 
IVR Plug-ins” on page 37.

To use a sample configuration, simply route calls to the extension of the IVR Plug-in 
for that configuration. For instructions routing calls, see “Route Calls to the Call 
Classifier” on page 34.

Tips on Using Agent Routing via Area Codes Sample

A sample Microsoft Access database, Agentregions.mdb, is provided with a pre-
defined Query to support this configuration (it is located by default at C:\Program 
Files\TeleVantage Call Classifier\Agentregions.mdb). The database contains all North 
American area codes with a field where you can enter the extension responsible for 
that area code. By default all area codes are handled by extension 100. Before using 
this configuration, you should edit the database to specify the extensions you want for 
each area code. For instructions on editing a database, refer to your Microsoft Access 
documentation.

For tips on updating the database with area code changes, see “Update Agent Regions 
Database As Area Codes Change” on page 12.

Tips on using TDMI DigitalDATA Sample

To use this configuration, you must have a link to the TDMI DigitalDATA service. See 
“Get Caller Information with ThinkDirectMarketing, Inc.” on page 27.

To test a case where a match is found in the sample contact database, you can do either 
of the following:

• Edit the MyContacts.mdb database using Microsoft Access, and add a contact 
record with a phone number that matches your caller ID. See your Microsoft 
Access documentation for instructions.

• When prompted to enter a phone number, enter a number that’s in the MyContacts 
database, for example 617 354 0600. Note that to be prompted, you must edit the 
caller prompting settings (click ) and uncheck “Prompt caller only if Caller ID 
number is empty.” For more information about caller prompting, see “Prompt 
Caller to Enter Number” on page 16
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Update Agent Regions Database As Area Codes 
Change

The sample database Agentreions.mdb contains all North American area codes with 
descriptions of each region. However, as time goes by new area codes are often added 
and old ones are split into multiple regions. Please note that Toshiba does not provide 
updated versions of this database as area codes change.  For your convenience we 
have included two ways for you to obtain the most up-to-date area code information. 

• North American Numbering Plan Administration NANPA (www.nanpa.com) is the 
official organization that manages the North American dial plan and publishes 
future area code changes.  While they do not provide a database of area codes 
themselves, they work with companies like Telcordia who produce a database 
called the NNAG that you can download and then import into Microsoft Access.  
The database can be downloaded from www.trainfo.com/products_services/tra/
nnagonly.html.  

• A web site at www.cs.ucsd.edu/~bsy/area.html contains a list of area codes 
casually maintained the cooperation of people on the Internet.  It is not an official 
site, but it does provide some very useful comments on each area code that do not 
exist in the Telcordia NNAG.  This is the site that was used to populate the 
included AgentRegions.mdb database. 

To use either of these data sources, you must use Microsoft Access or some other tool 
to organize the data into a searchable database table.   Microsoft Access’ File > Get 
External Data > Import option provides useful tools to import and format data 
appropriately for searching. For instructions on this and other Microsoft Access 
features, refer to Microsoft Access’ documentation.
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Add a Rule in Call Classifier
To have the Call Classifier process incoming calls, you create one or more rules that 
define which calls to affect, and what to do with those calls.

1. In the Call Classifier window, click 
Add. The Add new entry dialog box 
opens (shown right).

2. In the Match incoming call section, 
define which incoming calls this rule 
will affect using the following fields:

• When. Select one of the following 
fields by which to recognize 
incoming calls: 

• DID. The rule affects all calls 
that dial a specific DID number.

• Caller ID number or Caller ID 
name. The rule affects all calls 
beginning with certain caller ID 
information. 

Note If you choose caller ID number, you can automatically attach the caller’s 
address and other information to the call, using the ThinkDirectMarketing 
DigitalDATA service. See “Get Caller Information with ThinkDirectMarketing, 
Inc.” on page 27.

• Call Notes. Call notes are set by Strata CS features only, so a rule based on 
call notes would affect only calls previously handled by Strata CS, for 
example a call passed from one Call Classifier rule to another, or a call 
previously handled by a Strata CS user, auto attendant, or Plug-in that set the 
Call Notes.

• Custom Data. Like Call Notes, custom data is set by Strata CS features only, 
so the rule would only affect calls that were previously handled by 
Strata CS, including another Call Classifer rule, IVR-Plug-in, or auto 
attendant. If you select Custom Data, enter the Variable name of the custom 
data variable by which you will recognize calls.
Example: You could have an auto attendant set a Custom Data variable for 
product choice based on caller selection. Then the calls get sent to the Call 
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Classifier, which performs a database based query based on the selected 
product to return the quantity of the product left in inventory. The query 
result is placed in the Call Notes field. (For more information about custom 
data variables, see Strata CS Administrator Manual and the Strata CS Call 
Center Administrator Guide.)

• All calls. This rule affects all calls to the Call Classifier. The Call Classifier 
always contains at least at least one rule for All calls, so that all calls are 
processed in some manner.

• Matches this text. Use this drop-down list to choose when the criteria selected 
matches a call. You can match a call in the following ways:

• Matches this text. Compares the criteria to specific text. For example, 
compare the DID field of the call to the number 6173540600. Enter the 
custom text (for example, 6173540600) in the field below the drop-down 
list. Do not use dashes or spaces, since the number must exactly match the 
contents of the DID field. Select either Matches this text (the rule activates 
on all calls with DID 6173540600) or Does not match this text (the rule 
activates on all calls except those with DID 6173540600). Add multiple 
rules to match multiple text values.

• Begins with this text. Compares the beginning of the criteria to a specific 
custom text. For example, compare the beginning of the caller ID number 
field to 212, which will match all calls from the 212 area code. Enter the text 
(for example, 212) in the field below the drop-down list. Select either 
Begins with this text (the rule activates on all caller IDs beginning with 212) 
or Does not begin with this text (the rule activates on all caller IDs except 
those beginning with 212).

• Exists in this custom database. Compares the criteria to records in your 
company database. For example, compare the call’s caller ID to the phone 
numbers of everyone in your contact database. See “Using Custom Database 
Queries” on page 19 for further instructions.

Note Only one rule in the Call Classifier can use a custom database query. If you 
need to perform two different custom database queries on calls, use multiple 
configurations of the Call Classifier together. See “Use Multiple Call Classifier 
Configurations” on page 35.

• Exists in the TDMI DigitalData service. Compares the Caller ID number to 
the records in ThinkDirectMarketing’s DigitalDATA service to return the 
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caller’s address and other profile information. See “Get Caller Information 
with ThinkDirectMarketing, Inc.” on page 27 for instructions. This option is 
available for Caller ID number only. 

Note Only one rule in the Call Classifier can use a TDMI DigitalDATA query. 

3. To add custom information to matched calls, check “Change call data.” You can 
add information to Strata CS fields such as Call Notes or a custom data variable, or 
to existing fields such as DID or caller ID, replacing the information that comes in 
with the calls. The information can be seen by agents using the Strata CS Client 
Call Monitor, and is saved with the call in the Call Log.

Note To add information to a custom data variable, you must first have defined that 
variable in Strata CS. See Strata CS Administrator Manual for instructions.

To leave call information unchanged, leave the Change call data field unchecked.

To specify how to change call information, use the following fields:

• Change. Select the field of the call to which you want to add custom 
information. Information already in the field (such as a caller ID number) will 
be overwritten.

• To. Enter the information to write to the field. Anything already in the field will 
be replaced.

4. Use the Final action drop-down list to route the calls to a destination of your 
choice. For example, you could have rules that distinguish between eastern and 
western U.S. calls based on the area code of the caller ID number, and route them 
to different queues for eastern and western product support. You could also set up a 
rule that hangs up on known solicitors before they even reach the Strata CS system. 

Choose one of the following options:

• Transfer call to extension. Routes the call the Strata CS extension of your 
choice. Enter the extension in the Extension field.

• Continue to next rule. Sends the call to be processed by the next business rule in 
the Call Classifier list. See “Ordering Business Rules in Call Classifier 
Window” on page 9.

• Send call to voice mail. Routes the call directly to the voice mailbox of the 
Strata CS extension of your choice. Enter the extension in the Extension field.
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• Return call to routing list. Returns the call to the routing list that it came from, if 
applicable. For example, a user’s routing list may be set up to ring extension 
102, then call the Call Classifier at extension 555, and then ring extension 103. 
After the Call Classifier accepts the call and performs any processing, the call 
returns to the routing list and is sent to extension 103.

• Hang up call. Disconnects the call.

• Transfer call to extension (from database). Transfers the call to the extension 
returned by a custom database query. See “Using Custom Database Queries” on 
page 19. This option is only available if you selected a custom database query.

• Transfer call to voice mail (from database). Transfers the call directly to the 
voice mailbox of the extension returned by a custom database query. See 
“Using Custom Database Queries” on page 19. This option is only available if 
you selected a custom database query.

5. Click OK to add the rule to the Call Classifier list.

6. Repeat these steps to add as many rules as you want.

Prompt Caller to Enter Number
You can have the Call Classifier prompt callers to enter an identifying number, such as 
their phone number, account number, or support issue number. The Call Classifier can 
then identify the caller based on that number, and attach the number to the call in any 
supported field, such as caller ID, Call Notes, a custom data variable, etc. The number 
can then be viewed by the users who answer the call using the Client’s Call Monitor.

You can choose to have caller prompting “fill in” information only when it is missing. 
If the field to be populated already has information, the caller is not prompted. For 
example, if you’re prompting callers to enter a phone number to populate the caller ID 
number field, the prompt can be skipped for calls that already have a caller ID number. 
In this way all your calls will have a populated caller ID field, without disturbing the 
majority of callers.

➤ To use caller prompting

1. Check “Prompt caller for data entry” on the 
main window (shown right).
Stratagy CS Call Classifier User Guide    08/02



Strata CS Call Classifier
Prompt Caller to Enter Number
2. Click . The Prompt Caller for Data Entry 
dialog box opens (shown right).

3. From the Prompt caller using drop-down 
list, choose the prompt that Strata CS plays 
to callers. The list shows all .VOX files in 
the Call Classifier directory. For 
instructions on creating your own caller 
prompts, see the next section.

The text of the pre-recorded prompt files 
supplied with the Call Classifier are as 
follows:

• HomePhone.vox. “Please enter your 
home phone number, area code first, 
followed by the pound sign.”

• BusinessPhone.vox. “Please enter your business number, area code first, 
followed by the pound sign.”

• CustomerID.vox. “Please enter your customer id number, followed by the 
pound sign.”

• IncidentNumber.vox. “Please enter your incident number, followed by the 
pound sign.”

• IssueNumber.vox. “Please enter your issue number, followed by the pound 
sign.”

• AccountNumber.vox. “Please enter your account number, followed by the 
pound sign.”

• Invoice.vox. “Please enter your invoice number, followed by the pound sign.”

Note Do not choose Confirm.vox or NumberEneterd.vox as the caller prompt. These 
files are used for validation (see Step 5).

4. From the Store result in drop-down list, choose what field to store the entered 
number in. Any data already in the field is overwritten.

5. To use caller prompting only when the desired information is not present, check 
“Prompt caller only if __ is empty.” For example, if you selected CallerID number 
in Step 4, then the Call Classifier will only prompt callers to enter a number when 
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the CallerID number field of the call is empty. When there is a number in the 
CallerID number field, callers will not be prompted. 

6. If unchecked, all callers are prompted to enter a number, even if a number is 
already present. The number entered by the caller overwrites the number that came 
in with the call.

7. To have Strata CS repeat the entered number back to the caller, and prompt the 
caller to confirm their choice or reenter it, check “Prompt callers to validate what 
they entered.” If unchecked, Strata CS accepts the number entered without 
repeating it back to the caller for confirmation.

Note For number validation the Call Classifier uses the prompts Confirm.vox and 
NumberEntrered.vox. Confirm.vox says, “You entered <number>.” 
NumberEntered.vox says, “If this is correct press 1, otherwise press 2.”

8. If you are matching the entered number against records in a database (see “Using 
Custom Database Queries” on page 19), you can respond to non-matches by 
prompting the caller to reenter the number. For example, if every incoming caller 
must have an issue number, and a caller’s issue number does not exist in your issue 
database, the Call Classifier will prompt him or her to reenter it. The reenter 
prompt is repeated on failed matches for the number of times that you specify. If 
there is still no match, the call continues with no change to the field that would 
have been updated, and may be handled by the Call Classifier’s All calls business 
rule (see “All Calls Rule” on page 9).

To use this feature, enter a number other than 0 in “Reprompt __ times if the 
custom database query using this data returns no match.” If you do not want to 
reprompt callers, leave the value 0.

Creat Custom Caller Prompts
You can easily create your own caller prompts by recording the prompt as a greeting 
using the Strata CS Client or Administrator, then exporting the prompt as a .VOX file 
into the Call Classifier directory (by default C:\Program Files\Strata CS Call 
Classifier). When recording a custom prompt, be sure to tell the caller to press # to 
signify the end of the number (the Call Classifier uses the # only to detect the end of 
the digit string, and does not include the # in the resulting digit string stored in the 
field).
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Using Custom Database Queries
The Call Classifier can access your existing databases to identify calls and attach 
information, or transfer callers to different extensions based on the database result. For 
example, you could compare the incoming caller ID number to all the phone numbers 
in your contact database. If the caller ID is found, you could then attach information to 
the Call Notes of the call from that contact record, such as the date and order of the 
customer’s last purchase. The user taking the call would then see that information in 
the Strata CS Client’s Call Monitor, as shown below.

The Call Classifier can query any Microsoft OLE DB supported database, for example 
Microsoft Access, SQL Server, Excel, Oracle, etc.

A sample database is included with the Call Classifier, that includes U.S. area code 
and state information. See “About Sample Configurations” on page 9.

Setting up a database query is a two-step process:

• Create Query or Stored Procedure to Search Your Database

• Configure Call Classifier to Use Query or Stored Procedure
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Create Query or Stored Procedure to Search Your 
Database

This section describes creating a database query using Microsoft Access, and a stored 
procedure using Microsoft SQL Server. To create queries using other databases, refer 
to your database’s or Microsoft Access’ documentation.

Create Microsoft Access Query to Use with Call Classifier

This section shows an example of creating a database Query using Microsoft Access. 
The example uses the sample Microsoft Access database, Agentregions.mdb, 
provided with the Call Classifier. It describes creating a database query that receives 
caller ID number from the Call Classifier and returns the extension to which the call 
should be transferred. The same Query is used in the sample configuration “Agent 
routing via area codes.ini” (see “About Sample Configurations” on page 9).

For more information about using Microsoft Access, see its documentation.

1. Start Microsoft Access. Open the 
database Agentregions.mdb, located by 
default in C:\Program Files\Strata CS 
Call Classifier (shown right)

2. Click Queries in the left pane, then double-
click Create Query in Design View. The Show 
Table screen displays (shown right).

3. Using the Show Tables dialog box, add the 
table AreaCodeAgent to the Query by clicking 
it and clicking Add. When creating a Query, 
you must add the table(s) that contain the field 
with the data to which the information from 
the call (DID, caller ID, etc.) will be 
compared, and the field with the results that 
you want to attach to the call for display. 
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4. Click Close to close the Show Tables dialog box.

5. Add the necessary table fields 
to your Query by dragging 
them from the Table down to a 
column in the Query display.  
For this Query, drag the table 
field AreaCode into the first 
column, and the table field 
AgentExt into the second 
column (shown right). When 
creating a Query, you must 
always add the following table 
fields:

• The one which will be 
compared to the 
information from the call in order to find a match (in this example, caller ID 
sent by the call will be compared to the AreaCode field)

• The one that contains the result you want to send back to the Call Classifier (in 
this example, you want to send back the AgentExt, the extension of the agent 
that should handle the call).

6. Now you must define the name of the input parameter. This represents the 
information sent by the Call Classifier (in this example, the caller ID number).

Note The possible input parameters that the Call Classifier can send are Caller ID 
name, Caller ID number, DID, Call Notes, and Custom Data.

Choose Query > Parameters.  The Query Parameters dialog 
box opens (shown right).

7. Under Parameter, type a parameter name that represents the 
type of data being sent (in this example, type “CallerID”). 
The name can be anything you want, but make a note of it, 
as you will have to enter it into the Call Classifier exactly as 
entered here. Under Data Type, select Text.

8. Click OK to close the Query Parameters dialog box.

9. In the Criteria cell of the first column, type Left$([CallerID],3). 
This command tells Microsoft Access to compare the first three digits of the input 
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parameter to the contents of the AreaCode field. (The first three digits of the input 
parameter will be the area code of the caller ID number sent by the Call Classifier.)

When entering the Criteria for a Query, 
always include the name of input parameter 
surrounded by square brackets. Type the 
name of the input parameter exactly as you 
created it in Step 7 (shown right).

10. Save your Query and choose a name for it (in this example, name it “CallerID 
Query”). If you want, you can compare it to the “AreaCodeQuery,” the sample 
Query provided with the Call Classifier that performs the same task.

11. Close Microsoft Access.

12. Go to “Configure Call Classifier to Use Query or Stored Procedure” on page 23.

Create SQL Stored Procedure to Use with Call Classifier

This section describes creating a stored procedure using Microsoft SQL Server. For 
more information about using SQL Server, see its documentation.

1. Use a tool such as Microsoft SQL Query Analyzer to open your SQL database and 
add a new stored procedure.

2. Your stored procedure must have a single input parameter, which will correspond 
to the Caller ID, DID, Call Notes, or Custom Data string being passed by the Call 
Classifier.  The stored procedure must return a named recordset.  In the following 
example, the stored procedure is named myStoredProcedure, the input parameter is 
called @CallerID, and the returned recordset field is called Last Order.

CREATE PROCEDURE  myStoredProcedure
@CallerID as varchar(15)

AS 

BEGIN

SELECT TableName.CompanyName + TableName.LastOrder  as 
"Last Order"

FROM TableName

WHERE TableName.PhoneNumber = @CallerID

END
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Configure Call Classifier to Use Query or Stored 
Procedure

To create a Call Classifier rule based on your database query, do the following:

1. In the Call Classifier, click Add. To edit an existing rule, select the rule and click 
Edit.

2. Use the When drop-down list to select the call field that you want to compare to 
your database, for example, DID or caller ID. For more information, see “Add a 
Rule in Call Classifier” on page 13.

3. From the drop-down list just below When, 
select “Exists in this custom database 
query” (shown right).
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4. Click  to open the Custom Database 
Query Settings dialog box (shown right).

5. To select the database to search, click 
“Build data connection” to open the 
Microsoft OLE DB Data Link connection 
Wizard (shown right).

Select the appropriate provider to represent 
the database your query will search. Use the 
following guidelines:

• For a Microsoft Access database query, 
the best selection is Microsoft Jet 4.0 
OLE DB Provider.

• For a Microsoft SQL Server database 
query, the best selection is Microsoft 
OLE DB Provider for SQL Server.

• If you have another database or are 
unsure what to select, select Microsoft 
OLE Provider for ODBC Drivers. This 
is a generic provider that works will ODBC databases.
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6. Click Next to proceed to the Connection tab of the Wizard. This screen is different 
depending on your selection in the Provider tab. Click Help for assistance on 
filling out the Connection tab. 

7. When the Connection tab is complete, click Test Connection to test the connection 
to your database.

8. Most users can skip the Advanced tab. Use the Advanced tab only if you are 
familiar with database permissions.

9. Click OK to close the Wizard and return to the Custom Database Query Settings 
dialog box.

10. Fill in the Custom Query Properties 
section (shown right) with the names 
from your Query or stored procedure. 
The names must match exactly for the 
database query to work. The fields are 
as follows, illustrated by the examples 
from the previous sections:

• Query name. Enter the name of your Query or stored procedure. 
Microsoft Access example: “CallerID Query” 
Microsoft SQL Server example: “myStoredProcedure”

• Input parameter. Enter the name of the input parameter expected by your query 
or stored procedure. 
Microsoft Access example: “CallerID” 
Microsoft SQL Server example: “@CallerID”

• Result field. Enter the name of the database field that contains the information 
you want to extract as the result of the query.
Microsoft Access example: “AgentExt” 
Microsoft SQL Server example: “Last Order”

11. In the No result text field, enter the message that you want to return when there is 
no match in your database.
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12. Test your query by entering a sample 
input parameter in the Sample Value for 
field and clicking Test! (shown right). 

If the test query does not succeed, check 
that the spelling of the Input parameter 
and Result field is exactly the same in 
this dialog box as it is in the Microsoft 
Access Query.

13. When the test query succeeds, click OK to close the Custom Database Query 
settings dialog box and return to the Add New Entry dialog box.

14. You can attach the result of the database query to the call, in either the Call Notes 
field or a custom data variable. That is not required for this example, so uncheck 
Change call data.

If you check Change call data, select either Call Notes or Custom Data. You can 
select other call fields, but these are the only ones to which you can attach the 
result of the database query.

To choose Custom Data, you must have already created a custom data variable (see 
Strata CS Administrator Manual). Enter the variable name in Variable. The result 
of the query will be entered as the value of the variable, so make sure that the 
variable type matches the expected result. For example, if the database query 
returns an extension or phone number, a numeric variable would work, but if the 
database query returns text information, the variable must be of type String.

15. Select the final action to perform on the call. For this example, we want the Call 
Classifier to transfer the call to the extension returned by the database query, so 
select “Transfer call to extension (from database).”

For information about the other final actions, see “Add a Rule in Call Classifier” 
on page 13.

16. Click OK.
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Get Caller Information with 
ThinkDirectMarketing, Inc.

ThinkDirectMarketing, Inc. (TDMI) provides an online service called DigitalDATA 
that identifies incoming calls by caller ID and returns the caller’s mailing address, 
along with other profile information. This can be a significant cost-saving feature in 
call centers where agents traditionally ask each caller for an address and enter it 
manually, often introducing errors in the process. The Call Classifier features a built-
in link to the TDMI DigitalDATA service, enabling subscribers to automatically attach 
the DigitalDATA response to the call, so that caller address can be viewed 
immediately by agents and saved with the call. The query and response to 
DigitalDATA is made almost instantaneously, so that agents have the information by 
the time they answer the ringing call. The DigitalDATA service fees are applied only 
when a match is made and an address returned.

To save on fees, the Call Classifier builds a local cache of successful DigitalDATA 
matches. You can choose to query the local cache first, and query DigitalDATA only if 
a local a match is not found. This enables you to save the per-match DigitalDATA fee 
for your repeat callers.

Requirements for Using ThinkDirectMarketing’s 
DigitalDATA

To use ThinkDirectMarketing’s DigitalDATA service with the Call Classifier, you 
must have the following:

• An active Internet connection on your Strata CS Server computer, preferably high-
speed.

• A separately purchased license for the DigitalDATA service. See the next section 
for contact information, or contact your Strata CS reseller.
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Contact ThinkDirectMarketing
Before using the Call Classifier with ThinkDirectMarketing, you must purchase a 
license for their DigitalDATA service. You can contact them as follows:

• Web: www.tdmdigitaldata.com

• E-mail: Digitaldata@thinkdm.com

• Mailing address:

ThinkDirectMarketing, Inc.
470 West Avenue 
Stamford, CT 06902

• Phone: 

(877) 288-3282 x121

(203) 964-9411 x502
Edward Fleiss, VP DigitalData

• Fax: (203) 978-5872

Register Your Digital DATA License
Once you have purchased a DigitalDATA license from ThinkDirectMarketing, you 
must register and activate it before you can use it with the Call Classifier. 
ThinkDirectMarketing will supply you with two 9-digit codes, the Agent ID and 
Client ID. To register and activate your copy of DigitalDATA, e-mail 
DigitalData@thinkdm.com or call (203) 964-9411 x502.
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Test DigitalDATA Connection
After registering your DigitalDATA license, and before running the Call Classifier, 
you should test your connection to the DigitalDATA service by using the 
ThinkDirectMarketing Tester application included with the Call Classifier. The 
ThinkDirectMarketing Tester lets you type in a sample caller ID number and send it to 
the DigitalDATA service for identification.

By testing your connection before running the Call Classifier, you can be sure that a 
failure to connect represents a problem with the DigitalDATA connection.

If you have any problems using the ThinkDirectMarketing Tester, contact 
ThinnkDirectMarketing, Inc. for support. See their contact information earlier in this 
section. Toshiba cannot troubleshoot problems with the DigitalDATA connection.

➤ To test your DigitalData service

1. Start the ThinkDirectMarketing Tester by choosing Start > Programs > Toshiba 
Strata CS > ThinkDirectMarketing Tester.

2. Click the Phone 10 tab 
(shown right).

3. Use the Area Code and 
Phone Number fields to 
enter a North American 
phone number. Enter the 
phone number without 
hyphens or spaces, 
because that is how the 
Call Classifier will send 
CallerID.

To be sure that the sample 
phone number is in the 
DigitalDATA database, 
use any valid phone number that is answered by an Auto Attendant or live operator 
(e.g., your home office phone number).

4. Make sure the Return Type drop-down list is set to Both. The Call Classifier will 
use this setting to make its queries.

5. Click Search! to test the connection to the DigitalDATA Service. If the connection 
is successful, caller information appears in the bottom part of the Tester application 
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window. A successful test means that you are ready to use the DigitalDATA service 
with the Call Classifier.

Note If there are multiple matches, the Call Classifier will use only the first entry 
returned.

If the test returns no data, it may be that the number does not exist in the 
DigitalDATA database. Keep trying with different phone numbers, including the 
number you used in Step 3 of this procedure. If none of the numbers return data, 
contact ThinkDirectMarketing for support. See their contact information earlier in 
this section.

Toshiba does not support troubleshooting the ThinkDirectMarketing Tester 
application or the DigitalDATA connection.

Attach DigitalDATA Information to Calls
Once you have registered and activated your copy of DigitalDATA, you can set up a 
Call Classifier rule that attaches DigitalDATA’s caller information to calls. For an 
example of a rule that does this, see the sample configuration “TDMI DigitalData,” 
included with the Call Classifier (see “About Sample Configurations” on page 9).

➤ To attach DigitalDATA information to calls

1. In the Call Classifier, create a new 
rule by clicking Add, or edit an 
existing rule by clicking Edit.

If you click Add, the Add new entry 
screen displays (shown right).

2. From the When drop-down list, select 
CallerID number. 

3. From the drop-down list just below, 
select Exists in the TDMI DigitalData 
service.

4. The Search local cache for a match first field gives you the option of saving 
money on repeat callers. If checked, the Call Classifier searches a local cache for a 
match first, and calls DigitalDATA only if a match is not found. The local cache is 
compiled automatically by the Call Classifier from each successful DigitalDATA 
query, so it contains a record of all previous DigitalDATA matches. Since your 
Stratagy CS Call Classifier User Guide    08/02



Strata CS Call Classifier
Get Caller Information with ThinkDirectMarketing, Inc.
repeat callers will be in the local cache, the Call Classifier will not call 
DigitalDATA for them, and you will save on DigitalDATA’s per-match fees.

If unchecked, the Call Classifier always calls DigitalDATA to find a match. This 
option is more expensive but more accurate, because the DigitalDATA service is 
constantly updated with correct customer information. Your local cache might 
occasionally return outdated information for a caller.

Note See “Manage DigitalDATA Cache” on page 33 for tips on periodically purging 
old records from the local cache, so you don’t get outdated data over time.

5. The Change call data field defaults to Call Notes, meaning the caller information 
returned by DigitalDATA is attached to the Call Notes field of the call. To attach 
the information to a custom data variable instead, select Custom Data and enter a 
valid string variable name in the Variable field.

To specify how DigitalDATA information appears, click . See the next section, 
“Present DigitalDATA Information to Agents.” 

Note To attach information to a custom data variable, you must have first created the 
string variable using the Strata CS Administrator. See Strata CS Administrator 
Manual for instructions.

6. Select the final action to perform on the call. See “Add a Rule in Call Classifier” 
on page 13.

7. Click OK.

Present DigitalDATA Information to Agents
You can set the format in which DigitalDATA information appears to agents in the 
Call Monitor. DigitalDATA provides several pieces of information about the caller, 
including several pieces of address information, that you can arrange in any format 
you want. You can also provide agents with pre-written scripts by adding your own 
words to frame the DigitalDATA information. For example, an agent script populated 
with DigitalDATA information might say, “Thank you for calling, Mr. Jones. How’s 
the weather in Cambridge today?”

You can set separate formats for business and residential records returned by 
DigitalDATA.
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➤ To set the formats for DigitalDATA information

1. From the Add Item dialog box (see 
the previous section), click . The 
TDMI Result Settings dialog box 
opens (shown right).

2. Click either Business records or 
Residential records to set the format 
for that type of DigitalDATA record. 
You can set different formats for each 
type.

3. In the Result Format field, enter the 
format of the information the way you 
want it to appear. The Result Format 
field functions like a text editor, in which you can type, edit, and delete text. You 
can type your own call scripts here for agents that incorporate DigitalDATA 
information. 

To insert a piece of DigitalDATA information, select it in the Data Tokens list and 
click Paste. The information piece is added at the position of the cursor in the 
Result Format field. Most of the DigitalDATA data tokens are self-explanatory, but 
the following explanations may be helpful:
• Zip_4. The four-digit zip code suffix.

• SICn. The business’ Standard Industrial Classification code, which identifies 
the primary purpose of the business. To look up a business’ SIC code, you can 
use the following U.S. government website: www.osha.gov/oshstats/
sicser.html.

4. In the No Result Text field, enter the text that appears in the Call Monitor if no 
match is found for the caller ID number.

5. To automatically replace the call’s incoming caller ID name field with 
DigitalDATA information, check “Fill CallerID - Name field with values from 
TDMI.” For residential records, caller ID name is set to the DigitalDATA’s 
FirstName and LastName information. For business records, it’s set to 
DigitalDATA’s BusinessName information.

If unchecked, incoming caller ID name is left as is, unless modified by another 
business rule.

6. When you are finished setting the format, click OK.
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Manage DigitalDATA Cache
The Call Classifier maintains a local cache of DigitalDATA results, for the purpose of 
saving you DigitalDATA fees on repeat callers. Over time the local cache can grow 
large in size and can also hold outdated information. To edit it for size and accuracy, 
do the following:

1. Open Microsoft Access.

2. Open the file CCPlugIn.dat, located in the Call Classifier directory (by default 
C:\Program Files\Strata CS Call Classifier).

3. Click Tables in the left 
pane to display the list of 
tables, then double-click 
the table named Cache 
(shown right).

4. In the Cache table window, 
delete outdated records 
using either of the 
following methods:

• To automatically delete the oldest records, click Queries in the left pane and 
double-click the query PurgeCache. You are prompted to enter a cutoff date, 
and optionally a time. When you run the query all records older than that date 
and time are purged.

• To manually delete records, select them and choose Edit > Delete Record. For 
greater ease in selecting older records, click the DateStamp column header to 
sort the entries by date. 

5. When you are finished managing records, save the table and exit Access.
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View Call Classifier Information in Call 
Monitor

For users and agents to view information attached to calls by the Call Classifier, they 
must have the correct Call Monitor setup in the Strata CS Client, as follows:

• To view Call Notes, make sure the Notes pane is showing by choosing View > 
Notes Pane. You can also display Call Notes in the Notes column.

• To view the DID field, make sure the DID column in showing.

• To view caller ID number and name, make sure the Number column is showing.

• To view Custom Data, make sure the appropriate Custom Data column is showing. 
Custom Data items must be defined in the Strata CS Administrator to appear as a 
Call Monitor column.

To show or hide columns, make sure the Call Monitor is showing, then choose View > 
Current View > Show Columns.

Route Calls to the Call Classifier
For the Call Classifier to process calls, the Strata CS Server must be set up to route 
calls to the Call Classifier’s extension. This can be done in several ways depending on 
how you want calls to be managed. 

Route All Calls to Call Classifier
In this setup, Strata CS routes all incoming calls to the Call Classifier extension. If a 
Call Classifier rule is applied to the call, the call is routed according to the settings for 
that rule. If no rule is applied, the call is routed to your main auto attendant (or any 
extension you want for unmatched calls). In this way each incoming call will be 
evaluated by the Call Classifier’s business rules that you defined.

For this option, do the following:

1. Route all your trunks to the Call Classifier’s extension.

2. In the Call Classifier, make sure the All calls rule transfers calls to your main auto 
attendant (or any extension you want). See “Add a Rule in Call Classifier” on page 
13.
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Route Calls Based On Auto Attendant Selection
If a small subset of total incoming calls needs to be managed by the Call Classifier, 
consider directing only certain calls to the Call Classifier extension by having an auto 
attendant menu choice transfer calls to the Call Classifier. For example, to evaluate 
calls that will be handled by a sales group, add a menu choice to your main auto 
attendant to connect to sales (i.e. “For sales, press 2”). Then, instead of transferring 
the call to the sales extension, transfer it to the Call Classifier’s extension. The Call 
Classifier will manage the calls and then transfer them to the sales extension.

Route Calls Based On DID
If you are using the Call Classifier to identify a small 
number of incoming DID numbers, consider setting 
up the DID numbers to transfer directly to the Call 
Classifier. Therefore, these calls will be managed by 
the Call Classifier without the need for additional 
auto attendant options or setup within Strata CS.   Set 
this up within the Strata CS Administrator's IVR 
Plug-in view (shown right) by associating the DID 
numbers with the Call Classifier IVR Plug-in.

➤ Enter each DID number in the DID number field. 
Separate DID numbers with commas. When one 
of the DID numbers is detected by Strata CS, the 
call will be immediately transferred to the Call 
Classifier.

Use Multiple Call Classifier Configurations
You can create multiple Call Classifier configurations, and even process a call through 
multiple configurations. Each configuration can have a different set of business rules 
and can perform a different database query or DigitalDATA query. Because a single 
configuration can only perform one database query and one DigitalDATA query, you 
must use multiple configurations if you want to perform more than one query on a 
call.

Example: When support calls come in, you want to do a database query based on 
Caller ID number to see whether the customer is in your database, and attach the 
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customer record to the Call Notes field. You then want to do another database query 
that determines their last order date and attaches it to a custom data variable called 
“Last Order.” You would send calls to one configuration (for example, at x555) for the 
first database query, then to a second configuration (for example, at x556) for the 
second database query.

To use multiple Call Classifier configurations, you must do the following:

1. Define each configuration by saving different copies of the Call Classifier .INI file.

2. Register each configuration separately as an IVR Plug-in.

The steps are described in the following sections.

Step 1: Define Multiple Call Classifier Configurations
You define different configurations of the Call Classifier by saving different copies of 
its .INI file, as follows:

1. Choose File > Save As.

2. Specify a new filename, for example MyCC2.ini.

3. Click Save.

4. Repeat to create as many configurations as you want.

The Call Classifier’s title bar shows the name of the configuration currently loaded. 
All edits you make, such as defining business rules, apply only to the currently loaded 
configuration. To switch to a different configuration, choose File > Open and select a 
different .INI file.

Changes are saved automatically as you work, so you never need to save the currently 
loaded configuration. Use the File > Save As command only to create new 
configurations with different names.
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Step 2: Register Multiple Call Classifiers as IVR 
Plug-ins

You must register each different Call Classifier configuration separately as an IVR 
Plug-in, distinguishing them using a custom data variable called CCINI. To do so:

1. In the Strata CS Administrator, choose File > New > IVR Plug-in.

2. In the General section, enter data as described in “Register Call Classifier as 
Strata CS IVR Plug-in” on page 6.

3. Check “Set custom data when this IVR-Plug-in is called.”

4. Click . The Custom Data dialog box opens 
(shown right).

5. Click Add. The next Custom Data dialog box 
opens.

6. Define the custom data variable as follows:

• Name. Enter CCINI.

• Description. Enter a description of the 
variable.

• Data Type. Select String.

• Default value. Leave this field blank.
7. Click OK to close the Custom Data dialog box, then click OK to close the other 

Custom Data dialog box. You are returned to the IVR Plug-in dialog box.

8. In Variable Name, make sure CCINI is selected.

9. In Variable Value, enter the full path of the 
.INI file for this Call Classifier 
configuration. For example, C:\Program 
Files\TeleVantage Call 
Classifier\MyCC2.ini (shown right).

10. Click OK.

11. Repeat to create a separate IVR Plug-in for each Call Classifier configuration. For 
each one, enter CCPlugin.Classifier in Program ID and CCINI in Variable name. 
Set the Variable value field to the full path of that configuration’s .INI file.
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Modify Call Classifier .INI Settings
System settings for the Call Classifier application are defined in the initialization file 
for the Call Classifier. The file is called CCPlugIn.ini and by default is located in 
C:\Program Files\Strata CS Call Classifier. You might have multiple .INI files 
representing multiple configurations of the Call Classifier (see “Use Multiple Call 
Classifier Configurations” on page 35). 

➤ To edit Call Classifier .INI file

1. Open the .INI file in the Call Classifier by selecting File > Open.

2. Select Edit > Call Classifier INI file. The file opens in Microsoft Notepad. You can 
modify the following lines in the [Settings] section:

• Transfer. The extension to which the Call Classifier transfers calls if an 
unexpected error occurs while processing the call. By default the extension is 
8000, the default auto attendant extension.

• Logging. If set to On, the Call Classifier creates a log file that can help with 
troubleshooting problems. The log file is called DIDLog.txt and is placed in the 
location listed in LogPath.

3. When all values have been entered, save your changes and exit your text editor.

Troubleshoot Call Classifier
If you encounter problems with the Call Classifier, try the following:

• If you are using custom database queries, test them first using the Call Classifier’s 
built-in test feature. See “Configure Call Classifier to Use Query or Stored 
Procedure” on page 23.

• If you are using ThinkDirectMarketing’s DigitalDATA service, test that service to 
make sure you are connected properly. See “Test DigitalDATA Connection” on 
page 29.

• Try dialing into the Call Classifier. Remember, if calling from a station, your call 
should be transferred to the default extension since no DID is present. If calling on 
a DID number, your call should be transferred to the appropriate extension. If you 
receive a message “invalid extension” when calling the Call Classifier extension, 
make sure the Call Classifier is set up as an IVR Plug-in correctly (See “Register 
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Call Classifier as Strata CS IVR Plug-in” on page 6). Also make sure you have 
enough station licenses to allocate to the Call Classifier.

• Turn logging on in the Call Classifier .INI file by setting Logging to “On” and by 
setting the LogPath. (See “Modify Call Classifier .INI Settings” on page 38.) 
Check the log file to see if any errors are listed.
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